Principal Pc E Mac Os emails diferenciam maiúsculas de minúsculas?

Os emails diferenciam maiúsculas de minúsculas?



Há muita confusão sobre se os endereços de e-mail diferenciam maiúsculas de minúsculas ou não. Alguns dizem que sim, enquanto outros afirmam que não. Então, quem está certo? Neste artigo, veremos se os endereços de e-mail diferenciam maiúsculas de minúsculas ou não.

Os emails diferenciam maiúsculas de minúsculas?

O que torna um endereço de e-mail?

Um endereço de e-mail é composto de três partes - a parte local (também conhecida como nome de usuário), o sinal @ e a parte do domínio. Cada parte tem sua própria função e está sujeita a seu próprio conjunto de regras. Aqui está uma visão geral rápida.

De acordo com o padrão, a parte local do endereço de e-mail pode ter até 64 caracteres e pode ser composta por um conjunto limitado de caracteres. Isso inclui letras maiúsculas e minúsculas do alfabeto latino, números de 0 a 9, ponto e caracteres especiais. Os caracteres especiais incluem `[email protected] # $% ^ & * () _- + = [] {} ~. Ele está conectado à parte do domínio com o sinal @.

A parte do domínio pode ter até 255 caracteres. Ele pode conter letras do alfabeto latino (maiúsculas e minúsculas), números de 0 a 9 e hífen. O hífen não pode iniciar ou terminar a parte do domínio.

Símbolos internacionais também podem ser usados, embora mais sobre isso mais tarde.

É sensível a maiúsculas e minúsculas?

A resposta correta a esta pergunta é sim e não. De acordo com RFC 5321 , a parte local do endereço de e-mail diferencia maiúsculas de minúsculas. Isso significa que, em teoria, [email protegido] não é o mesmo que [email protegido]. No entanto, os provedores de email têm a liberdade de tratar as partes locais como diferenciando maiúsculas de minúsculas e não diferenciando maiúsculas de minúsculas.

Por exemplo, [email protected], [email protected] e [email protected] são teoricamente diferentes endereços de email. É fácil ver como isso poderia criar problemas e diminuir a experiência do usuário se um servidor de email optasse por tratar as partes locais como diferenciando maiúsculas de minúsculas. Portanto, muitos provedores tratam a parte local do endereço de e-mail como indiferente a maiúsculas e minúsculas.

o que acontece quando você bloqueia alguém na discórdia

Quanto à parte do domínio, RFC 1035 estipula que é sempre insensível a maiúsculas e minúsculas. Isso significa que você pode escrever em letras minúsculas, maiúsculas ou qualquer combinação dos dois e seu e-mail acabará no mesmo endereço. Na prática, [email protected], [email protected] e [email protected] são o mesmo endereço de email.

Na prática

Embora os endereços de e-mail sejam apenas parcialmente sensíveis a maiúsculas e minúsculas, geralmente é seguro pensar que eles não diferenciam maiúsculas de minúsculas. Todos os principais provedores, como Gmail, Yahoo Mail, Hotmail e outros, tratam as partes locais dos endereços de e-mail como não diferenciando maiúsculas de minúsculas. Dito isso, você deve verificar as regras do provedor de e-mail com o qual deseja criar um e-mail.

Vinculando-se ao ponto anterior, a RFC 5321 mencionada acima recomenda que novos endereços de e-mail sejam criados com letras minúsculas apenas para evitar possíveis confusões e problemas de entrega.

Por outro lado, se o seu amigo ou colega tem um endereço de e-mail com uma combinação de letras maiúsculas e minúsculas, é aconselhável escrevê-lo como se está enviando um e-mail. Não fazer isso pode fazer com que o e-mail não seja entregue. No entanto, isso não é um problema com os principais provedores de e-mail, como Gmail, Yahoo Mail, Hotmail e outros.

Além disso, o Gmail também é insensível a pontos encontrados na parte local do e-mail quando se trata de identificação da conta do usuário. Isso significa que se a conta [protegido por e-mail] existir, você não poderá se registrar [protegido por e-mail] ou [protegido por e-mail]

Internacionalização

Originalmente, os endereços de e-mail só podiam ser registrados usando as letras do alfabeto latino, números e um conjunto limitado de caracteres ASCII especiais. No entanto, o IETF (Internet Engineering Task Force) posteriormente desenvolveu regras e padrões para inclusão de caracteres internacionais.

RFC6530 foi o primeiro a incluir e regulamentar o uso de caracteres internacionais. RFC6531 expandido nas regras e padrões. Posteriormente, as regras e padrões foram atualizados por meio RFC6532 e RFC6533 .

Agora você pode registrar um endereço de e-mail usando uma ampla variedade de letras, caracteres e scripts. Alguns dos mais amplamente usados ​​incluem caracteres latinos com diacríticos, alfabeto grego, caracteres chineses tradicionais, caracteres japoneses (hiragana, katakana e kanji), alfabeto cirílico, várias escritas indianas, bem como uma variedade de outras.

A inclusão e a compatibilidade com endereços de e-mail internacionais variam de provedor para provedor. Mesmo alguns dos maiores provedores não são totalmente compatíveis com endereços internacionais. Por exemplo, o Google permite que você envie um e-mail para um endereço internacional, mas não permite que você crie um. O Outlook 2016 tem uma funcionalidade semelhante.

Conclusão

Ao contrário da parte do nome de domínio, a parte local de um endereço de e-mail diferencia maiúsculas de minúsculas. Dito isso, muitos provedores de e-mail optam por ignorar a diferenciação de maiúsculas e minúsculas da parte local por razões práticas e incentivam as pessoas a criar e-mails apenas com letras minúsculas.

Artigos Interessantes

Escolha Do Editor

Como converter cabo coaxial para HDMI
Como converter cabo coaxial para HDMI
Atualizado: 30/05/2021 Se você comprar uma TV nova, é provável que ela não tenha um conector coaxial. Ele pode ter vários conectores HDMI, USB e componente, mas nenhum coaxial. Se você tiver uma caixa de cabo ou satélite mais antiga
Posso definir o Google Maps como padrão em um iPhone? Não
Posso definir o Google Maps como padrão em um iPhone? Não
Muitos usuários gostam do Google Maps, especialmente porque funciona bem com outros produtos do Google. No entanto, os usuários do iPhone não obtêm o aplicativo por padrão e ficam presos ao Apple Maps inicialmente. Embora você possa obter o Google Maps,
Análise do Western Digital WD TV Live
Análise do Western Digital WD TV Live
O WD TV da Western Digital não era um reprodutor de mídia comum. Com pouco mais do que uma porta HDMI na parte traseira, sem armazenamento interno e sem recursos de rede, a simplicidade era sua palavra de ordem; conecte qualquer dispositivo de armazenamento em massa USB, seja
Como espelhar o Android em um PC ou laptop
Como espelhar o Android em um PC ou laptop
Com tantos dispositivos que as pessoas usam diariamente, querer conectá-los uns aos outros parece a coisa mais natural a se fazer. Dependendo da combinação de dispositivos que você possui, essa pode ser uma tarefa bastante simples.
Como desativar a aceleração de energia no Windows 10 [versões recentes]
Como desativar a aceleração de energia no Windows 10 [versões recentes]
As versões recentes do Windows 10 vêm com um novo recurso, chamado 'Power Throttling'. Aqui está como desativar o Power Throttling no Windows 10 versão 1709 e superior.
Como fazer um álbum no SoundCloud
Como fazer um álbum no SoundCloud
Se você é um aspirante a músico sem uma gravadora, provavelmente sonha em ser descoberto por um caçador de talentos um dia. Mas até então, fazer álbuns e carregá-los em uma plataforma conveniente como o SoundCloud pode ser de imenso
Como desativar o Adobe Flash no Edge
Como desativar o Adobe Flash no Edge
Por padrão, o Windows 10 é fornecido com o Adobe Flash Player incluído no sistema operacional. Se você sentir que não precisa mais dele, veja como desativar o Flash no Edge.